解决方法:云服务器ECS实例使用公网访问网站异常

网站编辑2021-12-27 11:22:28267

  问题描述
  

  在ECS实例访问公网网站时,在开发者工具的Elements区域中提示以下错误。

<script src="http://[$IP]/j/?ch"></script>

  具体错误如下图所示。


  
  说明:[$IP]为ECS实例的公网IP地址。
  
  问题原因
  
  该ECS实例的DNS服务器异常。
  
  解决方案
  
  1.确认对应页面的实际代码文件没有异常脚本存在。
  

  2.或者通过网络验证,查看是否存在异常脚本,如果是在Linux系统中遇到此问题,可以在Linux服务器中,执行以下命令,加上不同的User Agent进行curl测试,确认不存在异常脚本。

curl --user-agent "Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0" http://[$Website]

  
  说明:[$Website]为异常的网址地址。
  
  3.通过以上步骤测试,确认一般在特定网络下会存在异常脚本,推测DNS异常。
  

  4.可以尝试将DNS地址修改为阿里云的DNS地址,以下为阿里云的DNS地址,然后查看是否正常,并建议部署证书服务,通过HTTPS协议访问网站。

223.5.5.5
223.6.6.6

  以上就是关于“ECS实例使用公网访问网站异常”的相关解答,如果亲们还有什么不清楚的问题,可以直接咨询我们的在线技术客服!典名科技期待与您合作!

最新推荐

右侧广告图1
  • 云服务器 e 实例

    适合部署开发环境、代码存储库、微服务、测试和暂存环境

    ¥99.00/年

    特价优惠

  • 弹性公网IP

    弹性公网IP是可以独立购买和持有的公网IP地址资源。目前,EIP仅支持绑定到专有网络类型的ECS实例、专有网络类型的私网SLB实例、专有网络类型的辅助弹性网卡、NAT网关和高可用虚拟IP上。

    ¥0.04/小时

    带宽3折起

  • 专有宿主机

    物理资源独享、部署更灵活、配置更丰富、性价比更高等特点。专有宿主机为单租户独享物理资源,同时宿主机上可以灵活创建ECS云服务器,并和其他ECS云服务器一样,可以挂载云盘,可以通过VPC联通,具有高度的灵活性和使用便捷性。

    ¥9724.00/月

    年付85折,折扣优惠

右侧广告图2