Windows重启后Mysql数据库无法启动错误1067

网站编辑2022-01-13 14:59:24702

  WIndows服务器部署的是宝塔面板,重启服务器后Mysql数据库无法自启动了,通过Windows服务中启动报错1067,进程意外终止,通过CMD启动同样报错1067,本文介绍重启方法。


  Mysql数据库启动报错
  CMD Mysql数据库启动报错:
  系统错误。
  发生系统错误 1067.

  进程意外终止。


  Windows服务中数据库启动报错;
  错误 1067.

  进程意外终止。



  查看Windows事件日志

  报错分别如一下截图所示:





  查看Mysql错误日志,不然有可能找不到真正的错误原因,导致找不到问题的根源所在。最后在mysql安装目录找到data文件夹下扩展名是.err那个文件,打开查看错误信息
  220107 16:56:51 [ERROR] Failed to open log (file '.\mysql-bin.000010', errno 2)
  220107 16:56:51 [ERROR] Could not open log file
  220107 16:56:51 [ERROR] Can't init tc log

  220107 16:56:51 [ERROR] Aborting


  解决方案
  根绝报错分析,是因为Windows异常关机,导致MYSQL二进制日志写入报错,从而引发Mysql 数据库无法启动,处理方法是删除/重命名二进制日志文件,启动数据库会Mysql 会重新生成数据库文件。
  1、打开Windows任务管理器终止所有mysqld进程;

  2、打开mysql安装目录的data文件夹,重命名这2个文件:ib_logfile0 和 ib_logfile1


  3、重启mysql服务,测试服务器可以正常启动


最新推荐

右侧广告图1
右侧广告图2